My Device Forums
September 23, 2021, 03:11:14 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Apple TV IP driver is now available.  Download the trial today from www.mydevice.com.au
 
   Home   Help Search Login Register  
Pages: 1 2 [3] 4 5 ... 7
  Print  
Author Topic: Media Center  (Read 76854 times)
DLPaul
Regular
Newbie
*
Posts: 48


View Profile
« Reply #30 on: December 16, 2011, 10:39:09 AM »

Cool, let us know if you get it fixed . Have you look into adding more variables based on selection? A displaying ratings  would be nice too
Logged
Matt
Administrator
Sr. Member
*****
Posts: 419


It's my device...


View Profile WWW
« Reply #31 on: December 16, 2011, 10:47:15 AM »

Cool, let us know if you get it fixed . Have you look into adding more variables based on selection? A displaying ratings  would be nice too

Fixed it.  Turns out it was a directory issue.

I've also fixed the muting problem upon startup.

Will add variables for media type now and see what I can do about ratings.
Logged
DLPaul
Regular
Newbie
*
Posts: 48


View Profile
« Reply #32 on: December 16, 2011, 11:19:41 AM »

That was fast Matt.  Waiting now for updated version  Smiley
Logged
Matt
Administrator
Sr. Member
*****
Posts: 419


It's my device...


View Profile WWW
« Reply #33 on: December 16, 2011, 11:32:58 AM »

Cool, let us know if you get it fixed . Have you look into adding more variables based on selection? A displaying ratings  would be nice too

Well as far as I can tell, Microsoft don't expose the user set ratings via the API.  Don't think i can get access to them sorry.
Logged
DLPaul
Regular
Newbie
*
Posts: 48


View Profile
« Reply #34 on: December 16, 2011, 11:43:22 AM »

Thats ok Matt, more important is adding more variables and browse list for at least music.
« Last Edit: December 16, 2011, 11:46:54 AM by DLPaul » Logged
DLPaul
Regular
Newbie
*
Posts: 48


View Profile
« Reply #35 on: December 16, 2011, 01:07:39 PM »

Installed Beta 6, cover art still is not being populated on VP and iPad. Tried Media Audio variable to pop up hidden text boxes with Artist,Album and Song variables info and nothing happened. Matt, is possible to add "now playing" command to list ? And my 1st crash happened today, here's info :Description:
  Stopped working

Problem signature:
  Problem Event Name:   CLR20r3
  Problem Signature 01:   ehexthost.exe
  Problem Signature 02:   6.1.7601.17514
  Problem Signature 03:   4ce77974
  Problem Signature 04:   mscorlib
  Problem Signature 05:   2.0.0.0
  Problem Signature 06:   4e1539fa
  Problem Signature 07:   420f
  Problem Signature 08:   51
  Problem Signature 09:   C3ZBVNPURP4U1JQN4MVVH4VR2RHODDMP
  OS Version:   6.1.7601.2.1.0.256.48
  Locale ID:   1033

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt
Logged
Matt
Administrator
Sr. Member
*****
Posts: 419


It's my device...


View Profile WWW
« Reply #36 on: December 16, 2011, 01:29:19 PM »

Installed Beta 6, cover art still is not being populated on VP and iPad. Tried Media Audio variable to pop up hidden text boxes with Artist,Album and Song variables info and nothing happened. Matt, is possible to add "now playing" command to list ? And my 1st crash happened today, here's info :Description:
  Stopped working

Problem signature:
  Problem Event Name:   CLR20r3
  Problem Signature 01:   ehexthost.exe
  Problem Signature 02:   6.1.7601.17514
  Problem Signature 03:   4ce77974
  Problem Signature 04:   mscorlib
  Problem Signature 05:   2.0.0.0
  Problem Signature 06:   4e1539fa
  Problem Signature 07:   420f
  Problem Signature 08:   51
  Problem Signature 09:   C3ZBVNPURP4U1JQN4MVVH4VR2RHODDMP
  OS Version:   6.1.7601.2.1.0.256.48
  Locale ID:   1033

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt


Yeah that's not good.  Are you able to reproduce it and provide steps?

Ok coverart, can you display it in Safari?

There's no such thing as navigate to the "now playing" page.  I guess I could fake it by tracking the current media type and jumping to the appropriate page.  Will try it out.
Logged
DLPaul
Regular
Newbie
*
Posts: 48


View Profile
« Reply #37 on: December 16, 2011, 01:43:07 PM »

I will try to reproduce. I know that I had music playing and been jumping back and forward using following commands: my music ,artist, song . I did maybe like 10 jumps between.
Logged
Matt
Administrator
Sr. Member
*****
Posts: 419


It's my device...


View Profile WWW
« Reply #38 on: December 16, 2011, 01:48:04 PM »

Is there a keyboard shortcut that jumps to "now playing"?
Logged
DLPaul
Regular
Newbie
*
Posts: 48


View Profile
« Reply #39 on: December 16, 2011, 02:06:00 PM »

URL does not work in Safari, using IP adress webserver is telling the browser the coverart.jpg is a text file and using machine name getting Cannot open page. I did not find on my Microsoft keyboard any shortcut to now playing.  I was unable so far to reproduce that earlier crash. Now while jumping and pausing/playing one song a cover art appear on my VP but when I change to play another album is not generating cover art again.
Logged
DLPaul
Regular
Newbie
*
Posts: 48


View Profile
« Reply #40 on: December 16, 2011, 02:14:12 PM »

Isnt that Now Playing dynamicly populated? Maybe will show up on dynamic list?
Logged
Matt
Administrator
Sr. Member
*****
Posts: 419


It's my device...


View Profile WWW
« Reply #41 on: December 16, 2011, 02:21:11 PM »

URL does not work in Safari, using IP adress webserver is telling the browser the coverart.jpg is a text file and using machine name getting Cannot open page. I did not find on my Microsoft keyboard any shortcut to now playing.  I was unable so far to reproduce that earlier crash. Now while jumping and pausing/playing one song a cover art appear on my VP but when I change to play another album is not generating cover art again.

Are you sure you installed the new version?  MyDevice.dll should be 1.0.0.6.
It's correctly rendering as image/jpg for me.
Logged
DLPaul
Regular
Newbie
*
Posts: 48


View Profile
« Reply #42 on: December 16, 2011, 02:28:02 PM »

Matt,

Everytime you send new beta I do install your plug-in and update a driver to newer version. Just checked and it is 1.0.0.6
« Last Edit: December 16, 2011, 02:31:50 PM by DLPaul » Logged
DLPaul
Regular
Newbie
*
Posts: 48


View Profile
« Reply #43 on: December 16, 2011, 02:46:55 PM »

Matt,

While playing/changing songs and browsing randomly menu got two crashes, my WMC  showing me message "Program not responding: The Remote Control program stopped responding and you will be returned to WMC." I finally got cover art in VP (iPad still no no) but when I change album is stuck on same cover art.
« Last Edit: December 16, 2011, 02:51:25 PM by DLPaul » Logged
DLPaul
Regular
Newbie
*
Posts: 48


View Profile
« Reply #44 on: December 16, 2011, 04:33:50 PM »

Matt ,

I think I figured out missing cover art problem. Been playing albums and checking if cover cover art corresponding to that album is in the folder. I found that in my PC WMC check for cover art in the folder and if its not there I think it aquire it from internet however your driver checks only in folders. So thru driver gets displays only cover art in folders regardles what WMC on my PC shows. Is there any work around it or not? I have no problem displaing cover art using other drivers from same library. On the other hand my iPad still have issues with displaying any cover art. Also after playing for 20-30 minutes your plug-in crashes and displays only message in WMC that it stopped working. After I click "ok"  I need to restart WMC in order for driver to work again.
« Last Edit: December 16, 2011, 04:41:02 PM by DLPaul » Logged
Pages: 1 2 [3] 4 5 ... 7
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!